Download & Installation

Compatibility Notes

webgen should run on any platform which supports Ruby 2.0.0 or higher. It has been successfully tested on the following platforms:

  • Linux with Ruby 2.0.0 or higher

See the platform specific installation notes for more information!

Furthermore, webgen should also run on jruby 1.7.x (in Ruby 2.x compatibility mode) and rubinius but that has not been extensively tested.

Platform Specific Installation Instructions


There are a variety of Linux distributions out there with different package management systems. So we will focus on instructions for Ubuntu 14.10 here (which should also work for any recent Debian based distribution).

After running the following commands, webgen and all the mandatory dependencies are installed:

$ sudo aptitude install ruby2.0
$ gem2.0 install webgen --user-install

Ubuntu has packages for the old 0.4.x and 0.5.x versions of webgen. If you want to use one of these versions (not recommended), you just need to run sudo aptitude install webgen0.4 or sudo aptitude install webgen0.5.


First you need to install Ruby 2.0.0 (or better). This can easily be done by using the Windows RubyInstaller - just download the latest installation binary from their homepage and run it. After that open a command shell (select Start -> Run..., then enter cmd and click on “Ok”) and type in the following:

C:\> gem install webgen --user-install

Mac OS X

Mac OS X 10.10 comes with Ruby and Rubygems preinstalled, you just need to run the following in the Terminal application:

$ gem install webgen --user-install

Generic Installation Instructions

Using Rubygems

If you are using Rubygems, installing the latest version of webgen is as simple as executing

$ gem install webgen

After this command has finished, everything is ready for creating websites. Be sure to have a look at the optional dependencies which provide additional functionality.

Manual Installation

The latest version of webgen can always be downloaded from the Github releases page. After the download the package needs to be decompressed and then you can install webgen using the included setup.rb installation method:

$ ruby setup.rb config
$ ruby setup.rb setup
$ ruby setup.rb install

Make sure that you also install the mandatory and, if you need them, the optional dependencies.

Using the Repository Version

webgen uses git as its versioning system and webgen’s repository is hosted primarily on Github. The repository always contains a clean state of the current development version of webgen, i.e. webgen should always work when checked out from the repository.

To check out webgen use the following command:

$ git clone git://


The following list shows all mandatory and optional dependencies for webgen. If you use Rubygems, the mandatory dependencies are automatically installed. webgen can also make use of optional dependencies if they are installed. Note that webgen was tested against the specified versions but it should normally work with newer versions, too!

  • (mandatory) Ruby version 2.0.0 or higher. Since webgen is written in Ruby, you need the Ruby interpreter to run webgen.

  • (mandatory) cmdparse version 3.0.1 or higher

  • (mandatory) systemu version 2.5.0 or higher

  • (mandatory) kramdown version 1.3.0 or higher for enhanced Markdown support

  • (optional) diff-lcs version 1.1.0 or higher for showing changes in destination files

  • (optional) RedCloth version 4.1.9 or higher for Textile support

  • (optional) maruku version 0.6.0 or higher (another Markdown library)

  • (optional) rdiscount version 1.3.5 or higher (yet another Markdown library, but written in C for speed)

  • (optional) haml version 3.1.0 or higher for Haml support

  • (optional) sass version 3.2.0 or higher for Sass and Scss support

  • (optional) builder version 2.1.0 or higher for programmatic xml generation support

  • (optional) rdoc version 4.0 or higher for RDoc markup support

  • (optional) coderay version 1.0.0 or higher for syntax highlighting

  • (optional) erubis version 2.6.5 or higher for Erubis (enhanced ERB) support

  • (optional) archive-tar-minitar version 0.5.2 or higher for (gzipped) tar archives as sources

All these libraries can be installed via Rubygems (which is recommended).